为Blog安装了andotCoolCode插件。但是由于我写的大多数都是ActionScript代码,但是这个插件中偏偏又没有ActionScript高亮支持的文件,无奈只有自己做一个了。

目前的文件包括Flash 8 ActionScript和Flash Communicotion Server的绝大部分关键字、方法、构造器和对象,但不包含对组件方法的支持。

和我有同样需求的朋友可以这样做:

1. 首先在WordPress中安装CoolCode
2. 下载后面的文件:

3. 将其解压缩后复制到如下文件夹中(视具体安装路径而定);

1
/wordpress/wp-content/plugins/coolcode/PEAR/Text/Highlighter/

4. 打开coolcode.php,搜索下面的语句:

1
var $acceptable_lang = array('php', 'cpp', 'css', 'diff', 'dtd', 'javascript', 'html', 'mysql', 'perl', 'python', 'ruby', 'sql', 'xml', 'java');

将“actionscript”支持加入其中:

1
var $acceptable_lang = array('php', 'cpp', 'css', 'diff', 'dtd', 'javascript', 'actionscript', 'html', 'mysql', 'perl', 'python', 'ruby', 'sql', 'xml', 'java');

想偷懒的朋友可以直接下载已经修改好的

5. 修改完毕。效果可以看 这里

另:

如果要自行编辑高亮语法文件,可以参考 这里

留言

2006-02-26
次访问