sephiroth.it的站长好像爱上了开发firefox插件,自从推出Flash
Tracer
插件以来,这是他开发的第三个firefox插件了。

这个插件的功能是可以随意选择Flash
Player的版本。例如,我通常需要使用Debug版本的Flash
Player,但是前段时间测试新版Flash
Player的全屏效果
时,我又必须安装测试版的Flash
Player r9.0.18。现在好了,有了这个插件,可以随意在各个版本的Flash
Player之间切换。

flash\_switcher.png

这里可以下载这个插件,安装后,插件自带8个版本的Flash
Player(从2.0到9.0)。

使用的方法非常简单,只需要在插件上单击某个需要切换到的Flash
Player版本即可,插件会弹出一个对话框告诉你切换成功,然后自动刷新页面让切换的插件生效。

我大致了解了一下原理:firefox(windows版本)的Flash
Player插件其实只有一个文件:NPSWF32.dll,这个文件保存在firefox安装目录的plugins文件夹下,要切换firefox的Flash
Player插件,只需要替换掉这个文件即可。平常我都是通过替换这个dll文件来更新firefox的Flash
Player的。

在安装插件时,插件将各个版本的Flash
Player的NPSWF32.dll解压缩到下面的文件夹中:

X:\{userAppData}\Mozilla\Firefox\Profiles\{userProfile}\extensions\{2b5cfade-d133-429c-aea5-865911de4e1d}\chrome\plugins  

当执行切换动作时,插件将对应的dll文件复制到firefox安装目录的plugins文件夹,替换原来的插件。

因此,要添加一个新的插件,只需要添加一个目录,并将相应的NPSWF32.dll复制到这个目录中即可。下图是我添加了两个插件之后的插件目录:

flash\_switcher\_2.png

留言